Error when installing "Microsoft.TeamFoundation.Build.Client Version 11.0.0.0 required"

Jun 10, 2014 at 3:56 PM
Hi,

I attempted to install this application but it wants Microsoft.TeamFoundation.Build.Client Version 11.0.0.0 installed in the GAC.

I don't use VS2012, I use VS2013 so I don't have this version of the binary. Is there a way to ensure the correct dependencies are included?

Thanks
Coordinator
Jun 10, 2014 at 6:11 PM
Hi there,

I cannot copy the Microsoft DLLs. However I can create you, after few days, another custom build with the DLLs from VS2013.
Also you can contribute to the project and create another branch for the 2013 version. You need only to download the source and change the TFS DLLs.

Anton
Jun 10, 2014 at 6:16 PM
Thanks, I look forward to the custom build.

At this time I am just prototyping the work that you have completed to see how it works, I don't necessarily want to begin contributing to the project ... yet :)

Thanks
Jun 10, 2014 at 7:17 PM
I just wanted to let you know I was able to modify the source and hack it to the point where I could build and launch the application. This unblocks me for now.

Thanks
Coordinator
Jun 24, 2014 at 9:14 PM
Hi there,

You can find the new 2013 version : [https://testcasemanager.codeplex.com/releases/view/122083])
Also I have added different build configurations in the source code by default the Release/Debug/VisualStudio_2012 will include Version 11.0.0.0 of the TFS assemblies and the VIsualStudio_2013 build configuration is going to create a build with 12.0.0.0 Version. If you are curios how the code is working in the next few days I will create a new blog post in my site.

Anton
Coordinator
Jun 25, 2014 at 8:15 PM
Hi,

You can find here: http://aangelov.com/2014/06/25/specify-assembly-references-based-build-configuration-visual-studio/ more information how the code for the different versions is working.

Anton